I suggest you ...

Please mantain low dependencies in requirements linux client, or link statically

The current linux client or debian packages install perfectly in debian 6, 7 and 8, this means works in debian squeeze, debian wheeze and also recent stable

Please mantain that low level dependencies, inclusivelly i can make it work into debian lenny with customized xlib hacks.. great!

I noted that xlib-randr must be >= 1.3, if that could be more lower this anydesktop can be work in any linux including those that runs embebed..

another its making opciotnally the ranrdr (used for monitor strech and screen scaling over client monitor) integration

31 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    PICCORO “Герхард” McKAY LenzPICCORO “Герхард” McKAY Lenz shared this idea  ·   ·  Admin →

    11 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Deidecelis GonzálezDeidecelis González commented  · 

        hi, thanks for the tar.gz flavor.. its saves me and works for very older linuxes.. i prefer the anydesk event the teamviewer

        please fix the xrandr requeriment to amke it works in some linuxes that still use xorg 1.4 or lower..

        thanks in advance

      • PICCORO “Герхард” McKAY LenzPICCORO “Герхард” McKAY Lenz commented  · 

        Seems now this are solved, but i must download the rpm and converted with alien, also tested the 32bit debian package directly

        i tested the 2.9.3 version.. and only have one problem, if anydesk lost focus on linux, then when restore focus the keyboard does not respond.

        after some ssh connection keyboard again responds
        minimal glitches in older linux desktops but nothing serious...

        PLEASE MANTAIN THE COMPATIBILITY BEETWEEN OLDER VERSIONS AND NEWER!

        now i dont use any more the stupid teamviewer

      • PICCORO “Герхард” McKAY LenzPICCORO “Герхард” McKAY Lenz commented  · 

        currently with last 2.6.1 still can install into debian squeeze, that's great ..

        but i pretty aprerciate that also install in debian lenny.. avoid of gtk (due lenny can use the backports gtk from squeeze) the only problem its the libxcb-rand0 requirement.

        i tested under lenny by using the binary tar.gz generic linux download and wverithing works except the client view of remote desktops (when lenny must see other machines)

        thanks in advance, keep the great work!

      • Tyrone LuceroTyrone Lucero commented  · 

        as i said in the other thread, great now that some depends are low, but still GTK and some x11 depends like xrandr are little high..

        AnyDesk software made a great job keep as is but need still more low end depends to manange many linux remote users, specially low-end-machines due economical reasons

      • Tyrone LuceroTyrone Lucero commented  · 

        i wish to remember sometingh, make it priority remote desktop management, and let other things like audio, object paste, file transfer for later.. its important the minimun functionallity for made it usable in any version of xorg and linuxes

      • PICCORO “Герхард” McKAY LenzPICCORO “Герхард” McKAY Lenz commented  · 

        please, currently the lasted versions of anydesk works in debian squeeze , but for lenny need more lower xcb-libs specifically libxcb-rand << 1.4

        thanks in advance!

      • Tyrone LuceroTyrone Lucero commented  · 

        i revised and tested the new 2.3.1 on linux and low depends reamin, thanks for that, but still linux version have bugs!

        the stupid guindows versino does not have problems

      • Tyrone LuceroTyrone Lucero commented  · 

        please make it work on debian squeeze due still are use in some low end machines

      • VeGNUliVeGNUli commented  · 

        i used debian squeeze and lenny, due multiarch new features in ubuntu makes run slower in low end machines

        please provide a deb package for install compatible with gtk 2.18, libxcb 1.1.3 and libc6 2.7 as minimun suported versions

      • FernandoFernando commented  · 

        i use Debian Squeeze is most faster

      Feedback and Knowledge Base