I suggest you ...

bug: Some control keys not captured, remote keys end up "stuck"

Conditions to reproduce:

- Anydesk window connected to remote and in focus
- Press certain control key combinations (example: Control - Alt - V)

Result: key "press" and "release" events get captured wrongly by local PC *AND* remote, and then some key(s) end up "stuck" in wrong state on remote. (Ctrl stuck "pressed" in this example).

Only way to clear the condition is to (sometimes) repeat the same keypress multiple times until the wrong capture happens again (thus toggling the remote key status), or of course by disconnecting from the remote.

Request: fix AD keyboard hooking so it fully captures all keypresses from local while AD remote screen is in focus.

55 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Matthew shared this idea  ·   ·  Admin →

    12 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • FeralBytes commented  · 

        The keyboard keys sticking on the remote side is unbearable.... trying to type commands on the remote side causing a key to be typed 5 or six times makes work impossible. The cause is a high ping delay between the client and the host.

      • Quike commented  · 

        This f*cking problem won't let me do my work.
        The latest response from AnyDesk was from Feb. 2016, I guess they don't care about us

      • Dickjones commented  · 

        its an ugly problem. i found that opening windows On-Screen Keyboard resets the stuck key/s. leaving it open wont help but turning it on every time worked for me.
        FYI connecting from Win10 to Win7 on user side

      • anon commented  · 

        I have it still too, its not 100% there, but its there and recently I renamed multiple folder at once just because anydesk was holding that key.
        I experienced it through many versions, on both windows and linux builds, connecting solely to windows machines though

      • Anonymous commented  · 

        I just fixed the problem by click on keyboard item on top right of the screen and put that on Map 1:1

      • Jose commented  · 

        Simple Ctrl + C / V wont work, Alt+Tab, etc. etc...
        My OS: Win7, AnyDesk versions 3.4.0

      • Anonymous commented  · 

        Same problem here with Linux on support side (Version 2.6.1) and Windows (Version 3.1.1) on user side. I didn't find out which keys caused the problem and wasn't able to fix it. It made AnyDesk unusable for me.

      • Anonymous commented  · 

        Hi,
        I'm experience the same problem. This happens most of the times if I'm using a Microsoft Remote Desktop on the remote mashine which im connected to.

        Somtimes sending "Ctrl + Alt + Del" trough the menu unstucks them, sometimes not.
        Sometimes adapting the screen resolution unstucks them, sometimes not.
        Most of the time when connecting with TeamViewer to send the "Ctrl + Alt + Del" command helps to unstuck them. In those cases, even when I'm connected with TeamViewer, the CTRL key is stuck at the beginning, until I send "Ctrl + Alt + Del" trough the TeamViewer menu.

        I have encountered this problem in following versions of AnyDesk: 2.4, 2.5, 2.6 and 3.0 Beta

        Regards

      • Michael Corban commented  · 

        I have the same problem since the last update of the Linux client. Lots of wasted time because of this.

      • Christian Bönnhoff commented  · 

        We just bought a 5 seat licence and are not very amused about this problem! We are running into it very often... This tends to be a showstopper...

      • Anonymous commented  · 

        I don't know if this is related, but I have a keyboard issue where Ctrl+Alt+Shift+letter are not registered by the remote PC, meaning all 4 keys pressed at the same time. Using AD 2.3.0.

      • Alexandra commented  · 

        The same behavior after pressing Win key (+L, f.i.) and Any Desk connection in focus. After PC unlocking it is impossible to enter any text, because any letter pressed is considered as if a shortcut "Win_key + letter" is pressed.

        Fix: to press Win_key+L again with Any Desk NOT in focus.

        Sometimes it is too annoying.

      Feedback and Knowledge Base